SAP NetWeaver multiple vulnerabilities

Some vulnerabilities have been reported in SAP NetWeaver, which can be exploited by malicious people to conduct cross-site scripting attacks, disclose sensitive information, and bypass certain security restrictions, according to Secunia.

1. An unspecified error within SLD (System Landscape Directory) can be exploited to disclose version information via the /REP and /RWB directories.

2. Input passed via the “test” parameter to the testServlet servlet in the performanceProviderRoot application is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user’s browser session in context of an affected site.

3. Input passed via the “BSNAME” and “REQID” parameters to the Deployer servlet in Trust Center Service is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user’s browser session in context of an affected site.

4. An error within the authentication mechanism in the J2EE Engine can be exploited to bypass the authentication mechanism and e.g. cause a DoS.

Solution: Apply fixes.




Share this