Apple updates Java for Mac OS X 10.5 and 10.6

The latest Java updates from Apple deliver improved reliability, security, and compatibility for Java SE 6 and J2SE 5.0. Java for Mac OS X 10.5 Update 6 supersedes all previous updates of Java for Mac OS X 10.5. Java for Mac OS X 10.6 Update 1 supersedes the previous Java for Mac OS X 10.6.

Security content of Java for Mac OS X 10.6 Update 1

Multiple vulnerabilities in Java 1.6.0_15
Multiple vulnerabilities exist in Java 1.6.0_15, the most serious of which may allow an untrusted Java applet to obtain elevated privileges. Visiting a web page containing a maliciously crafted untrusted Java applet may lead to arbitrary code execution with the privileges of the current user. These issues are addressed by updating to Java version 1.6.0_17.

An expired certificate for a Java applet is treated as valid
An expired certificate for a Java applet is treated as valid. This issue is addressed through improved handling of expired certificates. Credit to Simon Heimlicher of ETH Zurich for reporting this issue.

Security content of Java for Mac OS X 10.5 Update 6

Multiple vulnerabilities in Java 1.5.0_20
Multiple vulnerabilities exist in Java 1.5.0_20, the most serious of which may allow an untrusted Java applet to obtain elevated privileges. Visiting a web page containing a maliciously crafted untrusted Java applet may lead to arbitrary code execution with the privileges of the current user. These issues are addressed by updating to Java version 1.5.0_22.

Multiple vulnerabilities in Java 1.4.2_22
Multiple vulnerabilities exist in Java 1.4.2_22, the most serious of which may allow an untrusted Java applet to obtain elevated privileges. Visiting a web page containing a maliciously crafted untrusted Java applet may lead to arbitrary code execution with the privileges of the current user. These issues are addressed by disabling Java version 1.4.2.

An expired certificate for a Java applet is treated as valid
An expired certificate for a Java applet is treated as valid. This issue is addressed through improved handling of expired certificates. Credit to Simon Heimlicher of ETH Zurich for reporting this issue.

Multiple vulnerabilities in Java 1.6.0_15
Multiple vulnerabilities exist in Java 1.6.0_15, the most serious of which may allow an untrusted Java applet to obtain elevated privileges. Visiting a web page containing a maliciously crafted untrusted Java applet may lead to arbitrary code execution with the privileges of the current user. These issues are addressed by updating to Java version 1.6.0_17.




Share this