Critical Shockwave Player vulnerabilities patched

Critical vulnerabilities have been identified in Adobe Shockwave Player 11.5.2.602 and earlier versions, on the Windows and Macintosh operating systems.

The vulnerabilities could allow an attacker, who successfully exploits the vulnerabilities, to run malicious code on the affected system. Adobe has provided a solution for the reported vulnerabilities. It is recommended that users update their installations to the latest version.

This update resolves a buffer overflow vulnerability that could potentially lead to code execution (CVE-2009-4002).

It also resolves multiple integer overflow vulnerabilities that could potentially lead to code execution (CVE-2009-4003).




Share this