Ruby on Rails bug is being exploited in the wild, researcher warns

Administrators of servers running Ruby on Rails are advised once again to upgrade to the latest versions of the framework (3.2.11, 3.1.10, 3.0.19, and 2.3.15), as a vulnerability that exists in previous versions is being actively exploited in the wild to rope servers into an IRC botnet.

According to security researchers Jeff Jarmoc, the attacks have been mounted from three domains, and deliver a payload that adds commands to crontab and downloads malicious source files and executables. The downloaded malware ultimately sets up an IRC bot that attempted to connect to one of two domains and to joint the #rails channel.

“The script uses a randomly generated 9 character nickname when connecting to IRC. “A lockfile “/tmp/tan.pid’ ensures the bot only executes once on an infected host,” he shared. “Functionality is limited, but includes the ability to download and execute files as commanded, as well as changing servers.”

Jarmoc is a little surprised that it took this long for the vulnerability – which was patched in January – to be exploited in the wild, but says that the fact that some admins haven’t upgraded their installations of Rails since then is less of a surprise.

He pointed out that the payload-serving domains, the additional downloaded malware, and the IRC server are now not available anymore, and that the attacks were likely performed by script kiddies.